Bug Report Forums
Report bugs and errors to the Flight Rising development team.
TOPIC | 400 bad request error?
1 2 3 4 5 6 7 8 9 10
Please continue browsing as normal and reporting anything that may be interesting. We have some additional tracing that may help us isolate exactly where the core issue is happening.
Please continue browsing as normal and reporting anything that may be interesting. We have some additional tracing that may help us isolate exactly where the core issue is happening.
Flight Rising Engineering Team

Flight Rising Knowledge Base
Flight Rising Rules & Policies
I was unable to access the cookie page, so I cleared cookies and was [i]finally[/i] able to log in to get the screenshots! [center][img]https://i.imgur.com/Y6xt08D.jpg[/img][/center] This is what I got immediately after log in. Will update with info if I get a 400 again! edit: got logged out, but no 400. after getting logged out: [center][img]https://i.imgur.com/ZdTTZQy.jpg[/img][/center] after clearing the excess cookie and logging back in: [center][img]https://i.imgur.com/BHYD8Z1.jpg[/img][/center] (also got logged out editing this message.) edit 2: had to clear cookies after visiting about five pages and having the site open, idle for about two hours. had a 400 and was unable to log in or visit any www1 url again. after clearing cookies this time: [center][img]https://i.imgur.com/ghxK2s1.png[/img][/center]
I was unable to access the cookie page, so I cleared cookies and was finally able to log in to get the screenshots!
Y6xt08D.jpg
This is what I got immediately after log in. Will update with info if I get a 400 again!

edit: got logged out, but no 400.
after getting logged out:
ZdTTZQy.jpg

after clearing the excess cookie and logging back in:
BHYD8Z1.jpg

(also got logged out editing this message.)

edit 2: had to clear cookies after visiting about five pages and having the site open, idle for about two hours. had a 400 and was unable to log in or visit any www1 url again.

after clearing cookies this time:
ghxK2s1.png
57DQFLh.png
Okay, it's not just me. I"m getting constant 400 Bad Request Errors.

The only solution I've been able to use is to constantly clear all my browser history/cache/cookies and flush my DNS. And then there's no guarantee it'll last.

I've had the error be gone for about 4 hours, or be back within 10 minutes. And FR is the only site it's happening on.


Info:
Win 10
Opera 67.0.3575.97
Personal Wifi / Tethered Hotspot / Home router (no change from any source)

Okay, it's not just me. I"m getting constant 400 Bad Request Errors.

The only solution I've been able to use is to constantly clear all my browser history/cache/cookies and flush my DNS. And then there's no guarantee it'll last.

I've had the error be gone for about 4 hours, or be back within 10 minutes. And FR is the only site it's happening on.


Info:
Win 10
Opera 67.0.3575.97
Personal Wifi / Tethered Hotspot / Home router (no change from any source)

LOOKING TO BUY:
5-dig Male Imp
Starting offers at 40kg pure!
I BUY RTT FODDER!
8,000T ea
9,000T ea for Windies
(PMs and PAs Welcome!)
SPACE PM ME FOR:
Murk/Beige/Spruce
Splash/White/Copper-Tarnish
forgot to add! The only extensions I have on chrome right now are New Xkit for Tumblr, View Image for google search, and Adblock plus, which I've disabled for FR for now, but am not disabling all together because I enjoy having my laptop disease free. Everything else I've disabled.
forgot to add! The only extensions I have on chrome right now are New Xkit for Tumblr, View Image for google search, and Adblock plus, which I've disabled for FR for now, but am not disabling all together because I enjoy having my laptop disease free. Everything else I've disabled.
f2u_cog_frog_by_dogi_crimson-dbvf4aj.giff2u_cog_frog_by_dogi_crimson-dbvf4aj.giff2u_cog_frog_by_dogi_crimson-dbvf4aj.giff2u_cog_frog_by_dogi_crimson-dbvf4aj.giff2u_cog_frog_by_dogi_crimson-dbvf4aj.gif
[quote name="clockworkMoose" date="2020-03-26 18:21:06" ] forgot to add! The only extensions I have on chrome right now are New Xkit for Tumblr, View Image for google search, and Adblock plus, which I've disabled for FR for now, but am not disabling all together because I enjoy having my laptop disease free. Everything else I've disabled. [/quote] @clockworkMoose Did you experience an unexpected logout or a 400 a little bit ago, between about 17:43 and 17:58 Server Time approximately? We are seeing requests that are arriving at our site with what appears to be zero cookies attached at that time, but no 400 or obvious reason why several requests in a row should have no cookies, which is very curious.
clockworkMoose wrote on 2020-03-26 18:21:06:
forgot to add! The only extensions I have on chrome right now are New Xkit for Tumblr, View Image for google search, and Adblock plus, which I've disabled for FR for now, but am not disabling all together because I enjoy having my laptop disease free. Everything else I've disabled.

@clockworkMoose

Did you experience an unexpected logout or a 400 a little bit ago, between about 17:43 and 17:58 Server Time approximately? We are seeing requests that are arriving at our site with what appears to be zero cookies attached at that time, but no 400 or obvious reason why several requests in a row should have no cookies, which is very curious.
Flight Rising Engineering Team

Flight Rising Knowledge Base
Flight Rising Rules & Policies
I'm not getting the 400 page today but I am getting logged out.

After logging back in:

Timestamp: 2020-03-26 18:29:20
Logged In: Yes
Overall Cookie Header Size: 4,317 bytes
Primary Login Cookie Size: 348 bytes
Auxiliary Login Cookie Count: 4

After using the tool:

Timestamp: 2020-03-26 18:30:13
Logged In: Yes
Overall Cookie Header Size: 1,458 bytes
Primary Login Cookie Size: 348 bytes
Auxiliary Login Cookie Count: 1
I'm not getting the 400 page today but I am getting logged out.

After logging back in:

Timestamp: 2020-03-26 18:29:20
Logged In: Yes
Overall Cookie Header Size: 4,317 bytes
Primary Login Cookie Size: 348 bytes
Auxiliary Login Cookie Count: 4

After using the tool:

Timestamp: 2020-03-26 18:30:13
Logged In: Yes
Overall Cookie Header Size: 1,458 bytes
Primary Login Cookie Size: 348 bytes
Auxiliary Login Cookie Count: 1
[quote name="@Mutron" date="2020-03-26 18:26:58" ] [quote name="clockworkMoose" date="2020-03-26 18:21:06" ] forgot to add! The only extensions I have on chrome right now are New Xkit for Tumblr, View Image for google search, and Adblock plus, which I've disabled for FR for now, but am not disabling all together because I enjoy having my laptop disease free. Everything else I've disabled. [/quote] @/clockworkMoose Did you experience an unexpected logout or a 400 a little bit ago, between about 17:43 and 17:58 Server Time approximately? We are seeing requests that are arriving at our site with what appears to be zero cookies attached at that time, but no 400 or obvious reason why several requests in a row should have no cookies, which is very curious. [/quote] Yes, I did! I had been checking cookies every 10-15 minutes all morning long, but then stopped for 3-4 hours. The only FR tab I had up was the cookie page. I clicked the homepage logo, got a 400 error, tried to back button to get the cookie page again, but it loaded up a 400 error there too, so I just cleared cookies, refreshed the cookie page (now with 0 cookies) and logged in. I haven't gotten any errors or extra cookies since. Since I didn't have any cookie screenshots from near before or after, I didn't post. But I did, the timeline matches up pretty well to when I came back to my computer.
@Mutron wrote on 2020-03-26 18:26:58:
clockworkMoose wrote on 2020-03-26 18:21:06:
forgot to add! The only extensions I have on chrome right now are New Xkit for Tumblr, View Image for google search, and Adblock plus, which I've disabled for FR for now, but am not disabling all together because I enjoy having my laptop disease free. Everything else I've disabled.

@/clockworkMoose

Did you experience an unexpected logout or a 400 a little bit ago, between about 17:43 and 17:58 Server Time approximately? We are seeing requests that are arriving at our site with what appears to be zero cookies attached at that time, but no 400 or obvious reason why several requests in a row should have no cookies, which is very curious.

Yes, I did! I had been checking cookies every 10-15 minutes all morning long, but then stopped for 3-4 hours. The only FR tab I had up was the cookie page. I clicked the homepage logo, got a 400 error, tried to back button to get the cookie page again, but it loaded up a 400 error there too, so I just cleared cookies, refreshed the cookie page (now with 0 cookies) and logged in. I haven't gotten any errors or extra cookies since.

Since I didn't have any cookie screenshots from near before or after, I didn't post. But I did, the timeline matches up pretty well to when I came back to my computer.
f2u_cog_frog_by_dogi_crimson-dbvf4aj.giff2u_cog_frog_by_dogi_crimson-dbvf4aj.giff2u_cog_frog_by_dogi_crimson-dbvf4aj.giff2u_cog_frog_by_dogi_crimson-dbvf4aj.giff2u_cog_frog_by_dogi_crimson-dbvf4aj.gif
[quote name="clockworkMoose" date="2020-03-26 19:22:06" ] Yes, I did! I had been checking cookies every 10-15 minutes all morning long, but then stopped for 3-4 hours. The only FR tab I had up was the cookie page. I clicked the homepage logo, got a 400 error, tried to back button to get the cookie page again, but it loaded up a 400 error there too, so I just cleared cookies, refreshed the cookie page (now with 0 cookies) and logged in. I haven't gotten any errors or extra cookies since. Since I didn't have any cookie screenshots from near before or after, I didn't post. But I did, the timeline matches up pretty well to when I came back to my computer. [/quote] @clockworkMoose Okay, and to confirm, these were 400s you received, as opposed to just a page where you were logged out? We are getting closer, thank you (and all the other posters!) for your responses.
clockworkMoose wrote on 2020-03-26 19:22:06:
Yes, I did! I had been checking cookies every 10-15 minutes all morning long, but then stopped for 3-4 hours. The only FR tab I had up was the cookie page. I clicked the homepage logo, got a 400 error, tried to back button to get the cookie page again, but it loaded up a 400 error there too, so I just cleared cookies, refreshed the cookie page (now with 0 cookies) and logged in. I haven't gotten any errors or extra cookies since.

Since I didn't have any cookie screenshots from near before or after, I didn't post. But I did, the timeline matches up pretty well to when I came back to my computer.

@clockworkMoose Okay, and to confirm, these were 400s you received, as opposed to just a page where you were logged out?

We are getting closer, thank you (and all the other posters!) for your responses.
Flight Rising Engineering Team

Flight Rising Knowledge Base
Flight Rising Rules & Policies
@mutron, yeah, the 400 page with Edgar.


(Before you posted the cookie testing page, I'd actually never come back to a "logged out" page. It was either the site worked fine, or that I would get the 400 page. I got my first "logged out" screen was yesterday when I was taking cookie screenshots. If the steps of the bug are "everything's fine", and then "logged out" and then "400 error page", I'd been skipping from step one to three and never saw the "logged out" stage.)

@mutron, yeah, the 400 page with Edgar.


(Before you posted the cookie testing page, I'd actually never come back to a "logged out" page. It was either the site worked fine, or that I would get the 400 page. I got my first "logged out" screen was yesterday when I was taking cookie screenshots. If the steps of the bug are "everything's fine", and then "logged out" and then "400 error page", I'd been skipping from step one to three and never saw the "logged out" stage.)

f2u_cog_frog_by_dogi_crimson-dbvf4aj.giff2u_cog_frog_by_dogi_crimson-dbvf4aj.giff2u_cog_frog_by_dogi_crimson-dbvf4aj.giff2u_cog_frog_by_dogi_crimson-dbvf4aj.giff2u_cog_frog_by_dogi_crimson-dbvf4aj.gif
@Vark @wittykitsune @OverlordPony

When you have trouble what is the first symptom? Do you get a 400 suddenly, or are you suddenly logged out and then only receive the 400 after several page loads?

Thanks for your patience everyone -- we are getting closer.
@Vark @wittykitsune @OverlordPony

When you have trouble what is the first symptom? Do you get a 400 suddenly, or are you suddenly logged out and then only receive the 400 after several page loads?

Thanks for your patience everyone -- we are getting closer.
Flight Rising Engineering Team

Flight Rising Knowledge Base
Flight Rising Rules & Policies
1 2 3 4 5 6 7 8 9 10