Bug Report Forums
Report bugs and errors to the Flight Rising development team.
TOPIC | Exalting problem
1 2 3 4 5
Every time I exalt a dragon, and I press ok it will not return me to the lair page and it’s stuck like that unless I refresh. This is also because there is no “x” to close the pop up
Every time I exalt a dragon, and I press ok it will not return me to the lair page and it’s stuck like that unless I refresh. This is also because there is no “x” to close the pop up
hHAqYnn.png
I’ve been having this issue as well. At first the OK button used to work most of the time so it didn’t bother me as much, but now I have to refresh every time I exalt a dragon since we have no other way of closing that popup.

For me this was on mobile, I haven’t tried exalting on PC yet.
I’ve been having this issue as well. At first the OK button used to work most of the time so it didn’t bother me as much, but now I have to refresh every time I exalt a dragon since we have no other way of closing that popup.

For me this was on mobile, I haven’t tried exalting on PC yet.
MRgR0YO.png
I'm having the same problem since yesterday, though I'm on PC so this isn't a mobile only bug :/
I'm having the same problem since yesterday, though I'm on PC so this isn't a mobile only bug :/
I am also having this problem on mobile!
I am also having this problem on mobile!
11511.png
Same problem, I'm on a Mac and using Chrome.
It's been happening for a few weeks for every other dragon I exalt, now it's all of them.
Same problem, I'm on a Mac and using Chrome.
It's been happening for a few weeks for every other dragon I exalt, now it's all of them.
wing2_by_youngarchaeologist-dc7xojy.png
gen 1 collector • exalter • female
coli challengeswishlist
Update:
I’ve cleared the history and cache but it’s still happening. Again this is still happening on all of my devices all on chrome
Update:
I’ve cleared the history and cache but it’s still happening. Again this is still happening on all of my devices all on chrome
hHAqYnn.png
I tested yesterday on mobile using safari and I exalted two dragons with no problem, but still having problems on PC (forgot to mention is on chrome)
I tested yesterday on mobile using safari and I exalted two dragons with no problem, but still having problems on PC (forgot to mention is on chrome)
I’m also having this problem on chrome, it’s the only browser I use. I use it on all devices, both with wifi and data.
I’m also having this problem on chrome, it’s the only browser I use. I use it on all devices, both with wifi and data.
mh8jR2Z.gif
http://www1.flightrising.com/forums/adopt/1093392
I've been having this problem for a while now. It's not bothering me too much because I can just use arrow keys to go to the next dragon, but I figured I should say something because bugs aren't great.

(Chrome on a Macbook, for reference.)
I've been having this problem for a while now. It's not bothering me too much because I can just use arrow keys to go to the next dragon, but I figured I should say something because bugs aren't great.

(Chrome on a Macbook, for reference.)
item_potted_peacevine_by_dogi_crimson-dab1dq1.gif call me dusk | he/him | fr time+8 mspABfO.gif
I have been having the same issue too. It has been doing this for about 2 weeks. I am on a PC using Chrome.
I have been having the same issue too. It has been doing this for about 2 weeks. I am on a PC using Chrome.
sfs_sprite_banner_colored_small1_by_inudoragon23-d9oz15t.png
1 2 3 4 5